Assembly Cache Viewer

.NET Framework Developer's Guide
Assembly Cache Viewer
DropDown image

The Assembly Cache Viewer is a Windows shell extension that allows you to view and manipulate the contents of the global assembly cache using Windows Explorer.

Using the Assembly Cache Viewer

You can do the following with the Assembly Cache Viewer:

  • View the contents of the cache.

  • View and change cache size limits for download.

  • View an individual assembly's properties.

  • Add assemblies to the cache.

  • Delete assemblies from the cache.

  • Display help information.

To view the contents of the assembly cache

  • Navigate to the \assembly subdirectory of the Windows directory, <System Drive>:\<Windows Folder>\assembly, in Windows Explorer. The contents of the global assembly cache are displayed.

    Shfusion.dll causes the contents of the assembly folder to appear differently than the contents of normal Windows folders. The names of the assemblies installed in the global assembly cache are displayed, with details about each assembly's type, version, culture, and public key token.

    Shfusion.dll is located in the %windir%\Microsoft.NET\Framework\vx.x.xxxx folder, where vx.x.xxxx is the highest installed version of the .NET Framework. For example, if versions v1.1.4322 and v1.0.5000 are installed, v1.1.4322 is used.

The following screenshot shows the contents of the assembly cache displayed in the viewer.

Global Assembly Cache contents

To view and change cache size limits for download

  • Choose Configure Cache Settings from the Tools menu in Windows NT systems or the View menu in Windows 98 systems. Alternatively, you can use the Configure Cache Settings icon on the toolbar.

    The Cache Properties dialog box appears. The display resembles the traditional drive properties dialog box except that it shows the amount of cache space used, in megabytes.

The following screenshot shows the Cache Properties dialog box.

Cache Properties dialog box

To view assembly properties

  • Right-click the assembly name in the viewer and choose Properties from the shortcut menu.

    A Properties window appears which shows the assembly's name, version, culture, public key, the codebase from which the assembly came, and the last modified date of the assembly. You can also view an assembly's properties from the File menu.

The following screenshot shows the Properties window for the System.Data assembly.

Assembly Properties window

To add an assembly to the cache

  • Use Windows Explorer to drag the file that contains the manifest into the assembly cache directory. Only assemblies with strong names can be added to the cache.

If you have the .NET Framework SDK, you can also use the Global Assembly Cache Tool (Gacutil.exe) to add an assembly to the cache.

To delete an assembly from the cache

  • Right-click the assembly in the viewer and choose Delete from the shortcut menu.

You can also delete an assembly from the File menu, or you can use Gacutil.exe if you have the .NET Framework SDK.

To display help for the viewer

  • Use the F1 key, or choose Help Topics from the Help menu.

To make a suggestion or report a bug about Help or another feature of this product, go to the feedback site.


shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

Full Text Search and Index Debug Topic graphic
To make a suggestion or report a bug about Help or another feature of this product, go to the feedback site.